hpsa Abort request on C0:B0:T0:L0 FAILED. Aborted command has not completed after 30 seconds.

When you’re running Linux on a HP Proliant Server with a SmartArray Controller attached and have errors in Syslog like

hpsa 0000:0e:00.0: Abort request on C0:B0:T0:L0
hpsa 0000:0e:00.0: ABORT REQUEST on C0:B0:T0:L0 Tag:0x00000000:00000010 Command:0x28 SN:0x88896  REQUEST SUCCEEDED.
hpsa 0000:0e:00.0: ABORT REQUEST on C0:B0:T0:L0 Tag:0x00000000:00000010 Command:0x28 SN:0x88896  FAILED. Aborted command has not completed after 30 seconds.
hpsa 0000:0e:00.0: resetting device 0:0:0:0
hpsa 0000:0e:00.0: device is ready.

and disk IO hangs but the SmartArray Controller reports no problems at all

Smart Array P410i in Slot 0 (Embedded)

   array A (SAS, Unused Space: 0  MB)

      logicaldrive 1 (558.7 GB, RAID 1+0, OK)

      physicaldrive 2I:1:1 (port 2I:box 1:bay 1, SAS, 300 GB, OK)
      physicaldrive 2I:1:2 (port 2I:box 1:bay 2, SAS, 300 GB, OK)
      physicaldrive 2I:1:3 (port 2I:box 1:bay 3, SAS, 300 GB, OK)
      physicaldrive 2I:1:4 (port 2I:box 1:bay 4, SAS, 300 GB, OK)

then chances are high that you have one drive that is going to die very soon.

After some hours and some more IO stalls and kernel logs like above the disk status will hopefully change to this:

Smart Array P410i in Slot 0 (Embedded)

   array A (SAS, Unused Space: 0  MB)

      logicaldrive 1 (558.7 GB, RAID 1+0, OK)

      physicaldrive 2I:1:1 (port 2I:box 1:bay 1, SAS, 300 GB, OK)
      physicaldrive 2I:1:2 (port 2I:box 1:bay 2, SAS, 300 GB, Predictive Failure)
      physicaldrive 2I:1:3 (port 2I:box 1:bay 3, SAS, 300 GB, OK)
      physicaldrive 2I:1:4 (port 2I:box 1:bay 4, SAS, 300 GB, OK)

Now you know which disk is causing the problem and can replace it.

Samsung Spinpoint F1

Gerade eben ist wieder eine Samsung Spinpoint F1 in meinem Desktop-Rechner gestorben … das ist jetzt die vierte (!) Platte innerhalb von nur 8,5 Monaten.

  1. 12.02.2010 Samsung Spinpoint F1 HD103UJ SMART Self-test: Read failure
  2. 07.07.2010 Samsung Spinpoint F1 HD103UJ FAILED SMART self-check. BACK UP DATA NOW!
  3. 03.09.2010 Samsung Spinpoint F1 HD103UJ SError: { UnrecovData Handshk }, ES-Tool: RAM-Error
  4. 05.03.2011 Samsung Spinpoint F1 HD103UJ SError: { UnrecovData Handshk }, ES-Tool: RAM-Error
  5. 24.03.2011 Samsung Spinpoint F1 HD103SJ ES-Tool: AJ36 Bad Sector, SMART Extended offline Completed: read failure

Bisher wurde von Samsung zwar jede von mir eingeschickte Platte anstandslos getauscht … aber ich hätte doch gerne eine die länger als ein paar Monate durchhält.

Weiß jemand, ob diese Serie besonders oft von Ausfällen betroffen ist?

Wir haben ein Monster geschaffen!

Inspiriert durch Isotopps Artikel Ich habe ein Monster geschaffen! gibt es hier auch mal wieder einen techniklastigen Artikel von mir.

Unser bisheriger Backup-Server im Datacenter war ein betagter Proliant DL380 G3 und sollte durch etwas aktuelleres ersetzt werden, vorzugsweise mit mehr Plattenplatz als nur 6x 300GB im RAID10.

Aus wirtschaftlichen Gründen (es ist “nur” ein Backupserver) haben wir uns gegen einen Server von HP entschieden, nicht zuletzt weil die 1TB SATA-Platten von HP mit 299€/Stück einfach jenseits von gut und böse liegen im Vergleich zu aktuellen Preisen für nicht-HP SATA-Platten im regulären Handel.

Bei der Wahl des Chassis hatten sich mein Azubi und ich relativ schnell für das Chieftec UNC-410F-B entschieden – 4U, 10 5,25″-Einschübe und damit genug Platz für Platten. Außen an das Gehäuse kommt eine Schiene RSR-260 zwecks Rackmontage und fertig ist das Chassis.

Den Saft für den Server liefert das redundant ausgelegte 500W-Netzteil MRG-6500P, das mit seinen 8 Molex- und 2 SATA-Steckern vorläufig genug Anschlüsse liefert.

Beim Mainboard haben wir uns an das von Kris verbaute Asus P5Q Premium gehalten, mussten aber leider während der Testphase feststellen, dass von den 10 SATA-Ports nur 8 sinnvoll nutzbar sind und haben deshalb auch noch eine Adaptec 1430SA nachgekauft.

Auf dem Mainboard findet anschließend eine Intel Core2Quad Q9550 Boxed (C1) CPU, 4x 2GB RAM und eine beliebige Grafikkarte Platz.

Bei der Suche nach passenden Backplanes wurden wir bereits auf der Zubehörseite des Chassis fündig: 3 Backplanes SST-2131SAS verstauen insgesamt 9 Western Digital Caviar WD15EARS.

2 Backplanes bilden mit ihren je 3 Platten ein Software-RAID5 auf dem dann LVM mit einem striped Logical Volume aufsetzt – quasi ein RAID50, durch LVM aber komfortabler zu managen.

Debian Lenny 64-bit ist per PXE-Boot, USB-Stick oder USB-CDROM innerhalb von 10 Minuten installiert, anschließend installieren wir BackupPC und übernehmen die Config-Files vom alten Server.

Beim Partitionieren der Platten sollte man die Sektorgröße von 4kB beachten – “normales” Partitionieren, so wie es der Linux-Sysadmin gewohnt ist, lässt die Schreibperformance auf diese Partitionen auf wenige MByte/s einbrechen.

Wie man es richtig macht findet man im Wiki von brain4free: WD “Advanced Format” HD mit LINUX.

Mittels pvs -o+pe_start stellt man sicher, dass die Nutzdaten des LVM-Layers auf einem Vielfachen der Chunksize des RAID5 beginnen:

PV         VG     Fmt  Attr PSize PFree 1st PE
/dev/md1   debian lvm2 a-   1.36T 1.36T 192.00K
/dev/md2   data   lvm2 a-   2.73T    0  192.00K
/dev/md3   data   lvm2 a-   2.73T    0  192.00K

Da meine Chunksize 64kB beträgt, passt der Beginn der Daten an Stelle 192kB also:

md2 : active raid5 sdd1[0] sdf1[2] sde1[1]
2930152704 blocks level 5, 64k chunk, algorithm 2 [3/3] [UUU]

md3 : active raid5 sdg1[0] sdi1[2] sdh1[1]
2930152704 blocks level 5, 64k chunk, algorithm 2 [3/3] [UUU]

lvs -o+stripes,stripesize,devices

LV       VG     Attr   LSize #Str Stripe Devices
backuppc data   -wi-ao 5.46T    2 64.00K /dev/md2(0),/dev/md3(0)

Wer an dieser Stelle stutzig wird, hat offenbar schon mehrfach mit Software-RAID zu tun gehabt:

Bei einem RAID5 aus 3 Platten mit einer Chunksize von 64kB müsste die optimale Stripesize für das darüberliegende Logical Volume 128kB sein. Verschiedene Benchmarks haben aber zu meiner Verwunderung ergeben, dass die Write-Performance mit der 64kB Stripesize um 10-15 MByte/s höher lag als bei der rechnerisch optimalen Stripesize von 128kB.

Das auf dem LV liegende ext3 FS sollte ebenfalls passend angelegt werden: Mit dem mkfs.ext3 RAID stride calculator ergibt sich bei einem RAID0 über 2 “Platten” mit einer Stripesize von 64kB und einer FS-Blocksize von 4kB folgendes mkfs-Command:

mkfs.ext3 -b 4096 -E stride=16,stripe-width=32 /dev/data/backuppc

Damit erfolgen Schreiboperationen auf das Dateisystem nun in optimaler Weise.

Weitere Stellschrauben:

Das Optimieren der stripe-cache-size der 2 RAID5-Bricks von default 256kB auf 4096kB hat bei uns die lineare Writeperformance auf das LV von 180 MByte/s auf 300 MByte/s gesteigert; recht beachtlich, wie ich finde.

Update: ext3- und xfs-Benchmarks mit bonnie++ auf dem LV.

Update: Smart-Werte (sda+sdb = System, sdc = Spare, sdd-sdi = Daten)

Windows 7 64-bit auf Notebook Samsung R560

Die Installation von Windows 7 (64-bit) gestaltet sich auf dem Samsung R560 P8400 Madril mitunter etwas schwierig.

Hier gibts die Schnellanleitung:

  1. Man benötigt ein installiertes Windows XP/Vista/7 in der 32-bit Version, um das BIOS von Version 06LA (Auslieferungszustand) auf Version 09LA flashen zu können. Das BIOS gibts auf samsung.de im Download-Center
    Samsung Download-Center
    hinter dem Karteireiter Firmware:
    Download-Center: Firmware
  2. Das BIOS-Update ist wirklich ein Windows-Programm, das sich leider nicht in einer virtuellen Maschine entpacken lässt. Um ein installiertes 32-bit-Windows kommt man leider nicht herum.
  3. Windows 7 64-bit installieren
  4. Treiber für LAN, WLAN, Chipsatz, Grafik (1280×800), Sound, Bluetooth, Webcam etc. bringt Windows von Haus aus mit.
    Dennoch empfiehlt es sich, den passenden 64-bit Treiber für den verbauten NVIDIA GeForce 9600M-GT-Grafikchip zu installieren.
  5. Damit man mit dem Synaptics-Touchpad Klicken und Scrollen kann, besorgt man sich auch hier den passenden Treiber in 64-bit.
  6. Die noch fehlende Software Easy Battery Manager, Easy Display Manager (für Shortcuts mit Fn-Taste für Helligkeit, Sound, Standby, …) und Easy SpeedUp Manager (Lüftersteuerung) gibt es von Samsung leider nicht als 64-bit-Version für das R560 – wohl aber für das neuere R620.
    Glücklicherweise hat sich zwischen R560 und R620 an der Hardware nicht zu viel geändert, so dass die Software-Pakete problemlos auch auf dem R560 laufen:

    Samsung Download-Center: R620

Viel Spaß mit dem 64-bit Windows auf dem Samsung R560.

Anleitung zum Ersetzen des 1&1-Rootserver-Kernels auf openSUSE-11-Installationen

Wie bereits im Heise-Forum von mir zum Heise News-Artikel openSuse-Kernel auf 1&1-Root-Servern möglicherweise veraltet angemerkt, lässt sich der 1&1-eigene Kernel, der offenbar Sicherheitslücken aufweist und sich über die Paketverwaltung nicht aktualisieren lässt, relativ einfach durch den Standard-Kernel von openSUSE ersetzen.

Die folgende Anleitung wurde erfolgreich auf 3 Root-Servern bei 1&1 getestet (1&1 Root-Server S64 mit Athlon64 Single- oder Dual-Core-CPU, 1GB RAM, NVIDIA-Chipsatz (lspci.txt)).

Wie immer bei Anleitungen aus dem Internet gilt auch hier:

Verwendung der Anleitung auf eigene Gefahr. Zu Risiken und Nebenwirkungen fragen Sie Ihren kompetenten Systemadministrator!

Wir aktualisieren die lokale Datenbank des Paketmanagers und schauen uns an, wieviele Updates darauf warten, eingespielt zu werden:

zypper refresh && zypper patch-check

Die letzte Zeile der Ausgabe könnte z.B. so aussehen:

4 patches needed (2 security patches)

Das Release bzw. die Versionsnummer des aktuell laufenden Kernels lassen wir uns mit

uname -r

anzeigen:

2.6.27.31rootserver-20090819a

Durch den Zusatz “rootserver” können wir erkennen, dass hier der von 1&1 selbstgebackene Kernel läuft, den wir gerne ersetzen wollen.

Wir installieren den openSUSE-Standard-Kernel mittels

zypper install kernel-default

Wie ich durch eigene Tests herausgefunden habe, stört sich der SUSE-Kernel an dem Boot-Parameter ro (das Root-FS wird dadurch read-only gemountet, openSUSE mountet dies während der Boot-Phase offenbar selbst nicht read-write).

Ob wir davon betroffen sind, verrät uns

grep kernel /boot/grub/menu.lst

Die Ausgabe könnte z.B. so aussehen:

kernel /boot/vmlinuz-2.6.25.20-0.5-default root=/dev/md1 ro console=tty0 console=ttyS0,57600
kernel /boot/vmlinuz-2.6.25.20-0.5-default root=/dev/md1 showopts ide=nodma apm=off acpi=off noresume edd=off x11failsafe console=tty0 console=ttyS0,57600

Falls bei Euch das ro in der Zeile auftaucht, die mit kernel beginnt, solltest Du mit Deinem Lieblingseditor (z.B. vim oder nano) die Datei /boot/grub/menu.lst bearbeiten und das ro entfernen.

Die Angabe root=/dev/md1 ist darüber hinaus ein Indiz, dass im Server ein Software-RAID eingerichtet ist.

Überprüfen lässt sich das mit

cat /proc/mdstat

Tauchen hier ein oder mehrere md-Devices (md1, …) auf, so ist ein Software-RAID eingerichtet.

Bei den von mir aktualisierten 1&1-Root-Servern war die Datei /etc/mdadm.conf nicht vorhanden.

Diese Datei sollte unbedingt vorhanden sein und die aktuellen RAID-Einstellungen widerspiegeln, wenn man den SUSE-Kernel booten will:

test -e /etc/mdadm.conf && mv /etc/mdadm.conf /etc/mdadm.conf.backup
mdadm –detail –scan > /etc/mdadm.conf

Wichtig: Das initrd-Image muss neu gebaut werden, damit dies die mdadm.conf enthält:

mkinitrd

Die Fehler bzgl. des 1&1 Kernels ignorieren wir.

Anschließend via

reboot

den Server rebooten.

An dieser Stelle empfiehlt es sich, sich zu Diagnose-Zwecken über den seriellen Konsolen-Server von 1&1 mit dem Server zu verbinden – damit ist man in der Lage, dem Kernel beim Booten zuzusehen und eventuelle Unregelmäßigkeiten zu erkennen. Die Zugangsdaten zum Konsolen-Server findest Du im 1&1 Control-Center unter dem Menüpunkt Server-Verwaltung/Serielle Konsole.

Sobald der Server wieder erreichbar und Du per SSH eingeloggt bist, kannst Du mit

uname -r

prüfen, dass nun der SUSE-Kernel geladen wurde. Der aktuelle SUSE-Kernel (Stand 26.11.2009) für openSUSE 11.0 ist:

2.6.25.20-0.5-default

Damit ist das Update des Kernels abgeschlossen.

#quelle #payment #fail

Screenshot quelle.de am 05.08.2009 um 23:00 Uhr beim Versuch, per Kreditkarte zu zahlen

*fail*

Nachtrag:

Aug 5 23:01:18 gate daemon.info pppd[22148]: LCP terminated by peer
Aug 5 23:01:18 gate daemon.info pppd[22148]: Connect time 1440.0 minutes.
Aug 5 23:01:18 gate daemon.info pppd[22148]: Sent 9831702 bytes, received 173885908 bytes.

#quelle #payment #unfail

Scheiß Murphy!

Sysadminday

Einen schönen Guten Morgen und Happy Sysadminday zu all den Kollegen da draußen!

Kaum am Arbeitsplatz angekommen, versammelten sich auch schon alle Arbeitskollegen und Cheffe hielt eine kurze Rede.

Anschließend wurde feierlich ein Marmorkuchen (das hatte ich kürzlich dezent in ein Gespräch eingepflegt, dass ein Stück Marmorkuchen zum Sysadminday ja recht schick wäre) und ein Präsent, in Geschenkpapier gehüllt, überreicht.

Sysadmin-Kuchen, überreicht von den Arbeitskollegen

Bei dem Geschenk handelte es sich um ein hochwertiges Polohemd (auch noch in der richtigen Größe!) mit Stickerei am Kragen – wie man es von den Fussballmanagern aus dem TV gewohnt ist.

Sehr sehr nice, muss ich da mal sagen. Vielen lieben Dank an meine netten Arbeitskollegen und Chefs.

Der Kuchen wird natürlich geteilt – das Polohemd allerdings nicht :-)

DSL: Auf und Ab bei der Telekom (Teil 3)

Hier gehts zum 2. Teil der Telekom-Odyssee.

Montag, 15.06.09, 00:14 Uhr

Bei Ebay sehr günstig ein Thomson 546i DSL-Modem geschossen. Die Thomson-Modems sind laut diversen Foren die Geräte, die auch bei sehr schlechten Leitungswerten noch am ehesten synchron werden, wenn Fritz!Boxen und Speedports bereits aufgegeben haben.

Offtopic:

AVM verbaut in seinen Fritz!Box-Geräten und den Speedports für die Telekom den AR7-Chip von Texas Instruments.
Dieser ist nach einhelliger Meinung bei schlechten/langen Endkunden-Leitungen aber gerade nicht das Gelbe vom Ei.

Montag, 15.06.09, 09:00 Uhr

Da man von den Telekom-Mitarbeitern immer schief angeguckt wird, wenn man kein Gerät aus dem Hause Telekom benutzt, habe ich mir eben im T-Punkt den Speedport W 721V für eine monatliche Mietgebühr von 2,95 Euro bestellt.

Falls der ganze Kram mit dem Speedport ebenfalls nicht funktioniert, wird der kurzerhand zurückgeschickt: Die Kündigungsfrist beträgt nur angenehme 6 Werktage.

Mittwoch, 17.06.09

Der Speedport trifft ein.

Angestöpselt am Splitter ergibts sich das gleiche, trostlose Bild wie mit meinem D-Link DSL-380T:

Die Sync-LED blinkt und blinkt und blinkt…

Im Logfile des Speedports findet sich:

17.06.09 18:19:07 DSL-Synchronisierung beginnt (Training).
17.06.09 18:18:39 DSL-Synchronisierung beginnt (Training).
17.06.09 18:18:10 DSL-Synchronisierung beginnt (Training).
[…]

Donnerstag, 18.06.09

Hermes liefert endlich das Päckchen mit dem Thomson 546i DSL-Modem bei mir ab.

Leider auch hier keinen Erfolg in Sachen DSL-Synchronisierung :(

Mittwoch, 24.06.09

Da sich bisher seitens Telekom nichts weiter getan hat, geht morgen folgendes Schreiben in die Post:

Aufforderung zur Leistungserbringung

Schade.

DSL: Auf und Ab bei der Telekom (Teil 2)

Hier gehts zum 1. Teil der Telekom-Odyssee.

Seit dem 18.05. ist einiges passiert:

Mittwoch, 20.05.09

Der Adminblogger ruft die Entertain-Hotline (01805-373750) für “günstige” 14 Cent pro Minute an: da morgen Christi Himmelfahrt und damit Feiertag ist, möchte ich gerne wissen, ob sich heute noch ein Techniker um meinen nicht funktionierenden Triple Play-Anschluss kümmert.

Die allgemeine Antwort aus dem Callcenter lautete in etwa, dass die Außendienst-Techniker bis 20 Uhr arbeiten würden, es also noch Chancen gebe, dass sich ein Techniker dem Problem annehme.

Donnerstag, 21.05.09

Das gestern nix mehr passiert ist, muss ich hier nicht extra erwähnen, oder?

Der Adminblogger macht sich ein Bier auf und genießt den Feiertag.

Pimp my WLAN

Da der Adminblogger aktuell nicht die Dienste der Telekom in Sachen Internet in Anspruch nehmen kann (hierzu in Kürze mehr) und der Handyempfang auch nicht ohne Tücken ist, muss aktuell die WLAN-Verbindung zu meinem Nachbarn und Arbeitskollegen herhalten.

Da ich bereits ahnte, dass das mit der Telekom etwas länger dauern würde, hatte ich mir relativ zügig ein besonders empfindliches & leistungsstarkes USB-WLAN-Dongle besorgt:

Alfa Network AWUS036H USB Wifi Adapter mit RTL8187-Chipsatz

Das Gerät sendet mit 500mW und erreicht laut Datenblatt mit seiner 2dBi-Rundstrahlantenne selbst bis -96 dBm immerhin noch 1 Mbit/s Übertragunsrate.

Aktuelle Montage am Badfenster mit ca. 7m USB-Kabel zum PC:

Wifi Adapter am Badfenster montiert und Antenne mit Alufolie abgeschirmt

Vor dem Einsatz der Alufolie, die die Strahlung etwas mehr in Richtung Fritz!Box meines Arbeitskollegen ablenken soll:

Link Quality=45/64  Signal level=19/65

Nach dem Anbringen der Alufolie:

Link Quality=48/64  Signal level=26/65

Die Verbesserung der Signalstärke durch die Alufolie macht sich sehr deutlich in der max. Übertragungsrate bemerkbar :)

Handyempfang

Merke: Handy um 2 cm verrücken kann die maximale Download-Rate signifikant senken… oder steigern.

Aktuell liegt das Handy – in einer Mülltüte vor Witterungseinflüssen geschützt – auf dem Fenstersims.

Dort habe ich vollen Empfang mit HSDPA. Auf der anderen Seite des Fensters nur UMTS; den Unterschied merkt man deutlich.

Gruß vom Adminblogger, der per Bluetooth fröhlich durch die Wohnung funkt.

DSL: Auf und Ab bei der Telekom

Solche oder ähnliche Geschichten gibt es im Internetz viele zu lesen. Ich möchte Euch meine Erfahrungen mit der Deutschen Telekom als Privatkunde nicht vorenthalten.

Viel Spaß bei der Unterhaltung wünscht Euch der Adminblogger :)

Mittwoch, 22.04.09

Für heute ist der Umzug des Telefon- und T-DSL-Anschlusses beauftragt. Gleichzeitig werde ich damit Kunde mit einem Komplettanschluss von der DTAG: Internet kommt also künftig von T-Online und nicht wie bisher von KAMP (Die scheinen gerade Ihr Privatkundengeschäft eingestellt zu haben – finden sich nur noch Business-Angebote auf deren Webseite).

Gegen 10 Uhr ist der Telefonanschluss in der alten Wohnung bereits tot, es ertönt nur eine automatische Ansage beim Versuch eine Nummer zu wählen.

Wie von der Telekom angekündigt taucht gegen Mittag der versprochene Techniker in der neuen Wohnung auf und schließt die TAE-Dose an den Hausanschluss an, misst die Leitung durch etc.

DSL geht zu dem Zeitpunkt noch nicht in der neuen Wohnung. Laut Aussage der Hotline werden DSL-Anschlüsse nur nachts um 0 Uhr geschaltet. Das DSL-Modem synct bis 08:30 Uhr des nächsten Tages nicht.

Ouch

Freitag, 10 Uhr

Betreff: Reboot Core-Switche morgen früh zwischen 5:30 und 5:45 Uhr

Guten Morgen die Herren,

wir haben am WE Supportwochenende und müssen hier vorher unsere Core-Switche booten.

Der Reboot erfolgt im Abstand von 15 Minuten.

Es sollten keine Störungen auftreten, da die Architektur als HA ausgelegt ist.

Falls es doch zu Störungen kommt bitte ich im Vorfeld um Entschuldigung.

Samstag, 18:15 Uhr

Betreff: Re: Reboot Core-Switche morgen früh zwischen 5:30 und 5:45 Uhr

Hallo,

leider ist aus dem automatisierten Reboot ein Totalausfall geworden.

Einer der Core-Switche im Backbone ist ein Totalausfall und wir waren gezwungen, Teile der Infrastruktur umzubauen.

Die ist soweit wiederhergestellt und die Dienste stehen ohne Einschränkung wieder zur Verfügung.

Conrad – lass Dich überraschen

Am Sonntag wurde im Forum de Luxx die Info gepostet, dass es aktuell viele Gutscheine bei einer Bestellung bei Conrad gäbe – inklusive Versandkostenerstattung.

Also kurzerhand 2 Bestellungen aufgegeben – einmal einen USB-Stick und 4 Klett-Kabelbinder (um auf den Mindestbestellwert von 20 Euro zu kommen) und einmal einen USB-Stick plus SMD-Widerstand (ebenfalls wegen der 20 Euro).

Die erste Lieferung kam heute an: USB-Stick wie bestellt, Klett-Kabelbinder (5 Stück anstatt 4 – hat sich wohl jemand verzählt) und ein “Premium-Markenprodukt im Wert von 14,95”: Eine 4-fach Steckdosenleiste von Brennenstuhl. Inklusive Versand – dank zahlreicher Gutscheine – für gerade mal 3,22 Euro.

Bei der 2. Bestellung scheint irgendetwas schief gelaufen zu sein – in der Bestellbestätigungsemail von Conrad fehlt der USB-Stick und der Rechnungsbetrag beläuft sich auf 16,90- EUR.

Da dieses Paket per Nachname kommt stellt sich mir nun die Frage, ob mir der Postbote morgen neben dem Paket auch noch 16,90 Euro aushändigt.

Ich werde berichten!

Update: Der Postbote war gerade hier und hat das Paket ausgeliefert. Allerdings wusste der nichts von Nachnahme, auf dem Paket war auch kein entsprechender Aufkleber.

Im Paket befand sich alles bis auf den USB-Stick, der in ca. 2 Wochen nachgeliefert wird. Der Betrag auf dem ausgefüllten Überweisungsträger lautet auf 16,90- EUR.

Die -16,90 werde ich besser nicht überweisen und stattdessen die Nachlieferung abwarten :)

PROBLEM: anakin is DOWN

Um genau 4 Minuten vor Mitternacht macht sich der Emailclient auf dem E90 lautstark bemerkbar:

PROBLEM: anakin is DOWN

kann man in großen Lettern lesen. Absender: Nagios.

Per Remote-Management kann man sich das Logfile des Servers anschauen, welches um 23:55 Uhr lapidar verzeichnet:

Server power removed

Leider ist ein Grund für diese nächtliche Unterbrechung nicht verzeichnet.

Der Versuch, den Server aus der Ferne zu Starten ist leider nicht von Erfolg gekrönt, auch wenn das Logfile etwas anderes vermuten lässt:

Host server powered ON by: pinky.

Es bleibt leider bei einem alles andere als befriedigenden Ergebnis:

power: server power is currently: Off

Da vom Ausfall des Servers keine vitalen Services betroffen sind, entscheide ich mich für

Acknowledge this host problem

und wende mich wieder meinem abendfüllenden Film mit Will Smith in der Hauptrolle zu.

Gute Nacht.

Broadcom Corporation BCM4312 802.11b/g [14e4:4315]

Nach dem Sieg des Spieltriebs über die Vernunft musste sich der Adminblogger auch eines dieser neumodischen Netbooks zulegen – die Entscheidung fiel auf ein Lenovo IdeaPad S10e, welches ich bereits vor einigen Tagen bei einem Arbeitskollegen begutachten konnte.

Out of the box funktioniert eigentlich alles – außer WLAN – unter grml 2008.11 sowie openSUSE 11.0.

Das WLAN-Device von Broadcom gibt sich als [14e4:4315] zu erkennen:

# lspci -nn | grep Broadcom

02:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM5906M Fast Ethernet PCI Express [14e4:1713] (rev 02)
05:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g [14e4:4315] (rev 01)

Das intern per USB angeschlossene WLAN-Device lässt sich leider weder per bcm43xx-Modul noch dessen Nachfolger b43/b43-legacy zum Leben erwecken.

Allerdings wurde von Broadcom vor kurzem ein Treiber veröffentlicht mit dem WLAN funktioniert, ohne auf NDISwrapper angewiesen zu sein.

Wie bei You’re Special, Just Like Everybody Else im Blog zu lesen, lässt sich der Treiber relativ einfach einbinden.

Zuallererst stellt man sicher, dass ihr die Header-Dateien für Euren Kernel installiert habt. Je nach Distribution gelingt das mittels

(openSUSE) # zypper ref ; zypper in kernel-source linux-kernel-headers
(debian/grml) # apt-get update ; apt-get install linux-headers-$(uname -r)

Nun besorgt man sich von der oben erwähnten Broadcom Webseite die aktuelle Version des Treibers für seine Architektur, z.B.

hybrid-portsrc-x86-32_5_10_27_11.tar.gz

Es folgt das übliche Prozedere bei Archiven unter Linux:

tar xfz hybrid-portsrc-*.tar.gz

Das Modul sollte sich nun problemlos mittels

(openSUSE) # make -C /lib/modules/$(uname -r)/build M=$(pwd)
(debian/grml) # make -C /usr/src/linux-headers-$(uname -r) M=$(pwd)

übersetzen lassen. Anschließend noch ein

mkdir /lib/modules/$(uname -r)/extra
cp wl.ko /lib/modules/$(uname -r)/extra
depmod -a
modprobe -rv bcm43xx b43 b43legacy
modprobe -v wl

und es sollte nun ein neues Interface auftauchen, auf meinem Lenovo Ideapad mit openSUSE 11.0 z.B. eth1.

# dmesg | tail

müsste in etwa folgende Ausgabe produzieren:

ieee80211_crypt: registered algorithm ‘TKIP’
wl: module license ‘unspecified’ taints kernel.
eth1: Broadcom BCM4315 802.11 Wireless Controller 5.10.27.11

Das sollte es gewesen sein. Nach einem Reboot sollte das WLAN-Device nun automatisch auftauchen, eventuell müssen von Euch die bcm43xx- und b43-Module geblacklisted werden.

Viel Spaß mit Linux auf dem Ideapad S10e.

Supported ports: [ FIBRE ]

Kämpfe gerade auf Arbeit mit einem Dell Vostro 410 mit integrierter Realtek Gigabit-NIC RTL8111/8168B, die laut ethtool nur einen Fibre-Port, keinen RJ45-Port hat …

Supported ports: [ FIBRE ]
Supported link modes: 1000baseT/Full
Speed: 1000Mb/s
Duplex:Full
Port: FIBRE
[..]
Link detected: no

*nerv*

Update: Nach entsprechender Recherche und Lektüre im Netz der Netze war dann die Lösung, einmal den herstellereigenen Kernel-Treiber r8168 zu laden.

Anschließend lässt sich die NIC auch mit dem r8169-Modul betreiben. Grund ist wohl, dass r8169 nicht weiß, wie man die NIC aktiviert.

RJ11 bei DSL-Modems?

Das Ersatz-Modem für meinen DSL-Router, das DSL-380T von D-Link, hat zu meiner Überraschung keine RJ45-Buchse für die Verbindung zum Splitter, sondern die kleinere RJ11-Buchse.

Mein DSLSplitter von der Telekom wartet wie auch das alte Siemens-Modem mit einer RJ45-Buchse auf, dem D-Link Gerät liegt aber nur ein Kabel mit zwei RJ11-Steckern bei.

Ich war bis heute der Meinung, RJ45 sei der Defakto-Standard was die DSL-Verkabelung beim Endkunden angeht…

Bisher ist mir nur einmal RJ11 in dieser Hinsicht über den Weg gelaufen:

Siemens hat – total krank – einem Ihrer WLAN-Router mit integriertem Modem eine RJ11-Buchse spendiert und ein Anschlusskabel mit einem RJ11- auf einen RJ45-Stecker beigelegt.

Wie sieht das bei Euch aus?

Welche Bauform hat die Buchse an Eurem DSL-Modem/-Router bzw. Splitter?

DSL-Modem nach Stromausfall gestorben

Siemens DSL-Modem D:NTAD:1L R45:AE im BackofenWährend einer einstündigen Stromabschaltung am gestrigen Vormittag aufgrund von Arbeiten im Stromnetz von E.ON hat sich leider mein DSL-Modem in die ewigen Jagdgründe verabschieded.

Das DSL-Modem D:NTAD:1L R45:AE von Siemens ist dafür berüchtigt, dass es nach oft jahrelangem, reibungslosem Betrieb den Heldentod stirbt, wenn es dann mal für eine kurze Zeit nicht in Betrieb ist und die elektrischen Bauteile abkühlen.

Grund dafür ist scheinbar ein mit der Zeit austrocknender Kondensator im Schaltnetzteil des Modems.

Selbst nach 20 Minuten “Aufwärmen” des Geräts im Backofen bei schnuckeligen 50°C war das Gerät anschließend selbst nach Anlegen von 220V nicht wiederzubeleben.

Ersatz ist aber bereits bestellt: Ein D-Link DSL-380T wird das defekte Gerät hoffentlich ab Anfang nächster Woche ersetzen.

Bis dahin muss ich mit 50 kByte/s über die UMTS-Verbindung vom Handy via Bluetooth Vorlieb nehmen – was erstaunlicherweise recht stabil funktioniert.

Sogar meinen Lieblings-MP3-Stream DIGITALLY-IMPORTED Chillout kann man damit wunderbar hören.

Nur das Handy wird mit der Zeit durch die Dauerbelastung etwas warm :)